AdviceIssues with Corsair cpu cooler
Posted:

AdviceIssues with Corsair cpu coolerPosted:

APG
  • 2 Million
Status: Offline
Joined: Jan 27, 201012Year Member
Posts: 1,177
Reputation Power: 46
Status: Offline
Joined: Jan 27, 201012Year Member
Posts: 1,177
Reputation Power: 46
Hello! I have a PC I built a couple years ago and I haven't had issues for a while


But now I'm having a issue with the CPU cooler. It's a h100 Corsair platinum cooler, The cpu cooler and fans starts up fine and is detected by my computer because they work.. but they will turn all red including the fans after just a second or 2 and will start to run very hot.

I checked the ICUE software and the device isn't being recognized in the software.. it says "h100 pump" but no details that the pump is actually working or anything.. it just shows my Corsair ram still working.

Has anyone had this issue and figured out a fix? I called Corsair and they basically told me to do everything I've already done.. the cpu cooler is legit working.. it's just not cooling.
#2. Posted:
Adam
  • Discord Elite
Status: Offline
Joined: Dec 10, 201110Year Member
Posts: 5,931
Reputation Power: 19615
Motto: Here we! Here we! Here we **** go!
Motto: Here we! Here we! Here we **** go!
Status: Offline
Joined: Dec 10, 201110Year Member
Posts: 5,931
Reputation Power: 19615
Motto: Here we! Here we! Here we **** go!
Get a readout from an external program like HWInfo to check CPU temps.

Your pump is probably dead. Unplug all the fans and turn on the PC. If you can't hear the pump start, that would have confirmed it. If you want to confirm it further, do the below -

Check to see what fan header port the CPU pump is plugged into

Reference that within either the BIOS or HWInfo to see if it's registering a speed

If nothing, it dead
#3. Posted:
Konsumer
  • New Member
Status: Offline
Joined: Mar 16, 201012Year Member
Posts: 28
Reputation Power: 1
Status: Offline
Joined: Mar 16, 201012Year Member
Posts: 28
Reputation Power: 1
Corsair H100v2 here. My CPU was throttling recently, i7-7700k and noticed temps were most likely the cause so I went to get new thermal paste. This definitely helped temps at load and I was able to complete the campaign I was in the middle of when it started crashing. Corsair Link is what I downloaded afterwards because my AIO is plugged into the CPU_FAN header- which is what Corsair's docs say even though my ASUS mobo says otherwise. If it's in the wrong header it wont finish the POST. Hopefully your pump is still under the 5-year warranty if that's your issue.
#4. Posted:
21
  • Moderator
Status: Offline
Joined: Oct 05, 20138Year Member
Posts: 16,137
Reputation Power: 3067
Motto: Me big smarts. Brainy boy do learns much
Motto: Me big smarts. Brainy boy do learns much
Status: Offline
Joined: Oct 05, 20138Year Member
Posts: 16,137
Reputation Power: 3067
Motto: Me big smarts. Brainy boy do learns much
Sounds like it's time for a new cooler.
Users browsing this topic: None
Jump to:


RECENT POSTS

HOT TOPICS