Xbox 360WWE App Install Fails repeatedlyPosted:

  • New Member
Status: Offline
Joined: Jun 20, 2019
Posts: 1
Reputation Power: 0
I've been trying for days to re-download the WWE App on my 360. My son deleted it.

Here's the problem:

I download it. I go in the "Play Now."

Box comes up saying it "can't play certain material previously watched."

Never launches the App.


Return to WWE to play or download.

"Play Now" is gone..."Download again" is visible.

I go to settings, Storage, Hard Drive, Games/Apps....

WWE listed there...but it has yellow circle with exclamation mark.

When I enter folder there are 2 items:
"Unknown 360 Game" with a size of 0KB
"WWE Title Update Cache" with a size of 75MB.

It won't let me delete either one.

If I shut down the xbox and restart and go to the games/apps on the hard drive...

the WWE Icon is normal.

When I enter the WWE only lists the "WWE Title Update Cache" with a size of 75MB. I can delete that one.

WWE app is still not in my apps. It continually does this every time I re-download it.
Never launches the app..just gives me the message.."Can't play previous material."

Have tried everything listed on XBOX support to try. Everything.
Tried other various solutions on web.
Nothing helped.

Have tried to talk with someone via chat...but never get through.

Anyone else ever experience this or have a solution?
Users browsing this topic: None
Jump to: