You are viewing our Forum Archives. To view or take place in current topics click here.

PC build problem.Posted:

Status: Offline
Joined: Sep 17, 20161 Year Member
Posts: 4
Reputation Power: 0
I am building a pc and I have run into some problems. I have been looking at many videos online on how to build a PC and they all say you need to plug in the power supply CPU connector to the motherboard cpu connector to give the CPU power however on my board there is no such connector when I booted up the system for the first time with no GPU it wouldn't start do I need a GPU to boot it up even if its just the bios to see if everything worked?. Also the lack of power to the CPU could be another factor to this not booting up. I would like to know the communities thoughts on the matter please tell me if you need more info.
CPU: AMD Athlon X4 860K
Motherboard: newegg.com/Product/Product.aspx?I...6813128763
Powersupply: newegg.com/Product/Product.aspx?I...6817139148
#2. Posted:
13
  • Gold Gifter
Status: Offline
Joined: Oct 05, 20134 Year Member
Posts: 13,793
Reputation Power: 1055
dunkinee wroteI am building a pc and I have run into some problems. I have been looking at many videos online on how to build a PC and they all say you need to plug in the power supply CPU connector to the motherboard cpu connector to give the CPU power however on my board there is no such connector

https://i.gyazo.com/aa147986ed88e79423bbcce48b960d76.png
https://i.gyazo.com/666ea9586fd81dee5719981df42bd227.png
You're going to need to plug in CPU power if you want the system to boot. I'm not sure why you tried to boot without it plugged in?

dunkinee wrotewhen I booted up the system for the first time with no GPU it wouldn't start do I need a GPU to boot it up even if its just the bios to see if everything worked?.

Yes. You need some sort of display output, which is from your GPU. The 860k has no iGPU.
#3. Posted:
Status: Offline
Joined: Sep 17, 20161 Year Member
Posts: 4
Reputation Power: 0
Yes I know I have to give power to the CPU but I don't know how. Where is the cpu power connector on my board? And yes I do know I need the GPU in but do I need it to boot up the bios just to test stuff?
Jump to:
You are viewing our Forum Archives. To view or take place in current topics click here.