GeneralRouter NAT IssuesPosted:

Lood
  • Blind Luck
Status: Offline
Joined: Apr 18, 20117 Year Member
Posts: 1,040
Reputation Power: 887
Motto: world's greatest dad - gifted by Nasyr, YoungBoyNBS & Mikey
Hey guys, I made a post recently about my NAT type issues which you can find below.

Hey everyone,

Just so readers have an idea about the situation; I am currently in college. I wanted to get Philps Hue lights for my birthday a few years ago. I got them, and love them, however they need a router to function. My dorm room does not have a router by default, so I got one, now they work great. Preface over.

This killed two birds with one stone, as my college has only Moderate NAT available through their ethernet connection and the IT office is unwilling/unable to help. The router allowed me to port forward and get Open nat, but only on some games. For example, on my Xbox One X, most Call of Duty games say I have Moderate NAT, even though network tests say otherwise.

That's pretty much all there is to know. I would just like some help or suggestions to try. I've done everything I can think of so maybe one of you will be able to help. Thanks in advance.


Someone suggested setting up DMZ hosting which didn't fix my issue, it just seemed to make things worse. At the moment I have ports forwarded on my Xbox from 35-4700 on both TCP & UDP. If anyone has any suggestions I would seriously appreciate it.

Thanks again!

Edit:
Thanks for all the help everyone. I'm still having issues. I checked which ports are being used when I'm playing CoD and the right ports are definitely forwarded. I'll mess with it a bit more I guess


Last edited by Lood ; edited 1 time in total
#2. Posted:
nober555
  • 2 Million
Status: Offline
Joined: Dec 06, 20107 Year Member
Posts: 654
Reputation Power: 45
I know its been harder for some people to get open NAT on CoD games being they now run on dedicated servers in stead of P2P servers.

What I would suggest to do is find the ports that the CoD games you want to play are and just have those ports forwarded and not a range of ports. (in my own experience having a range of ports offers just about no benefit) I believe that CoD games now use 3075 and 3076, let me know if this is any help.
#3. Posted:
Lood
  • 1K Rainmaker
Status: Offline
Joined: Apr 18, 20117 Year Member
Posts: 1,040
Reputation Power: 887
Motto: world's greatest dad - gifted by Nasyr, YoungBoyNBS & Mikey
nober555 wroteI know its been harder for some people to get open NAT on CoD games being they now run on dedicated servers in stead of P2P servers.

What I would suggest to do is find the ports that the CoD games you want to play are and just have those ports forwarded and not a range of ports. (in my own experience having a range of ports offers just about no benefit) I believe that CoD games now use 3075 and 3076, let me know if this is any help.
i don't believe my specific router type allows me to do that. I have a NETGEAR n600 model WNDR3400v3 I think. In the port forwarding settings I can only type in ranges instead of specific ports
#4. Posted:
Tele
  • Gold Gifter
Status: Offline
Joined: Jan 30, 20144 Year Member
Posts: 1,719
Reputation Power: 108
Lood wrote
nober555 wroteI know its been harder for some people to get open NAT on CoD games being they now run on dedicated servers in stead of P2P servers.

What I would suggest to do is find the ports that the CoD games you want to play are and just have those ports forwarded and not a range of ports. (in my own experience having a range of ports offers just about no benefit) I believe that CoD games now use 3075 and 3076, let me know if this is any help.
i don't believe my specific router type allows me to do that. I have a NETGEAR n600 model WNDR3400v3 I think. In the port forwarding settings I can only type in ranges instead of specific ports


Then use port 3075-3076 range.
#5. Posted:
Nasyr
  • Gold Gifter
Status: Offline
Joined: May 28, 20135 Year Member
Posts: 1,174
Reputation Power: 6659
Motto: Website Developer and MyBB Developer | Steam ID: imnasyr | Xbox Gamertag: Im Nasyr | I give back to the community when I can.
I recommend making sure you have an ethernet cable in directly. Setting up an I.P reservation for your console directly before you Port Forward. Then of course, open the specific ports to that I.P address allocated to your Xbox One. Here is a list of ports you should have open for Call of Duty, if you need more for certain Call of Duty games or any game let me know.

Call of Duty: WWII - Xbox One
TCP: 3074
UDP: 88,500,3074,3544,4500
#6. Posted:
Lood
  • E3 2016
Status: Offline
Joined: Apr 18, 20117 Year Member
Posts: 1,040
Reputation Power: 887
Motto: world's greatest dad - gifted by Nasyr, YoungBoyNBS & Mikey
Nasyr wroteI recommend making sure you have an ethernet cable in directly. Setting up an I.P reservation for your console directly before you Port Forward. Then of course, open the specific ports to that I.P address allocated to your Xbox One. Here is a list of ports you should have open for Call of Duty, if you need more for certain Call of Duty games or any game let me know.

Call of Duty: WWII - Xbox One
TCP: 3074
UDP: 88,500,3074,3544,4500

Just so you all know what I'm working with here are all the settings available to me in port forwarding. I previously had it set to TCP & UDP with my port range starting at 35 and ending at 4700. I'll update the settings with what's recommended above and get back to you all with an update to the OP
[ Register or Signin to view external links. ]
#7. Posted:
Nasyr
  • Gold Gifter
Status: Offline
Joined: May 28, 20135 Year Member
Posts: 1,174
Reputation Power: 6659
Motto: Website Developer and MyBB Developer | Steam ID: imnasyr | Xbox Gamertag: Im Nasyr | I give back to the community when I can.
Okay I'm not sure the process on Netgear routers for basically setting a static I.P address. So what I would recommend is opening the ports as you would in port forwarding and give them an I.P of like .55.

Xbox One Console
1. Home > Settings > Network > Advanced Settings.
2. Note down everything you see, it'll look like this; [ Register or Signin to view external links. ]
3. Hit I.P Address
4. In here choose Manual and type in the I.P address in which we set for the ports (xxx.xxx.x.55).

Enter the subnet mask which is usually; 255.255.255.0.
Enter the gateway I.P from your router, usually; 192.168.0.1.

Go into DNS settings inside of Advanced Settings.
Enter your primary and secondary DNS you noted down way at the start.

Now go back to Network settings and test your connection.

Check and see if it makes any difference. I wouldn't usually do it this way but may work.
#8. Posted:
Lood
  • 1K Rainmaker
Status: Offline
Joined: Apr 18, 20117 Year Member
Posts: 1,040
Reputation Power: 887
Motto: world's greatest dad - gifted by Nasyr, YoungBoyNBS & Mikey
Nasyr wroteOkay I'm not sure the process on Netgear routers for basically setting a static I.P address. So what I would recommend is opening the ports as you would in port forwarding and give them an I.P of like .55.

Xbox One Console
1. Home > Settings > Network > Advanced Settings.
2. Note down everything you see, it'll look like this; [ Register or Signin to view external links. ]
3. Hit I.P Address
4. In here choose Manual and type in the I.P address in which we set for the ports (xxx.xxx.x.55).

Enter the subnet mask which is usually; 255.255.255.0.
Enter the gateway I.P from your router, usually; 192.168.0.1.

Go into DNS settings inside of Advanced Settings.
Enter your primary and secondary DNS you noted down way at the start.

Now go back to Network settings and test your connection.

Check and see if it makes any difference. I wouldn't usually do it this way but may work.
Hey Nasyr,

If you see this, your steps listed gave me Open NAT but games like CoD still say I have Moderate. Anything else you think I could try?
#9. Posted:
r00t
  • PC Master Race
Status: Offline
Joined: May 18, 20117 Year Member
Posts: 15,583
Reputation Power: 6577
You're behind the NAT of a firewall/router you don't have access to. You said you have your own router, but this only creates a sub-network inside of the campus network you're on. Depending on how the school's network is designed, you probably share the same public IP with many other users.

To get a public IP address with ports forwarded to your console, you'll need to use a VPN.
#10. Posted:
NutsNotHanginOut
  • Shoutbox Hero
Status: Offline
Joined: Apr 25, 20144 Year Member
Posts: 470
Reputation Power: 812
Motto: Just leave them out...
I think you're port-forwarding incorrectly.

It should be as follows;

Service Name: (Whatever you wanna name it)
Service type: TCP or UDP or Both
External Starting Port: 3074
External Ending Port: 3074
Click for the check mark on "use the same port range for internal port" section
Internal Starting Port: 3074
Internal Ending Port: 3074
For internal IP address you need to make sure its your Xbox's IP.

The ports that Nasyr said are the correct ports for Call Of Duty, the current gen cods. For old gen cods the ports are different. I set the ports to both UDP, and TCP.

Make sure you restart your router and restart your xbox by holding/pushing the power button on your console for 10 seconds.
Users browsing this topic: None
Jump to:


RECENT POSTS

HOT TOPICS