GeneralWhy is my frame rate low no matter what the settings are?Posted:

Status: Offline
Joined: Sep 27, 20153 Year Member
Posts: 2
Reputation Power: 0
My laptop is the Dell Inspiron 15 7657.
Specs:
Intel Quad core i7 7700HQ
16GB DDR4
GTX 1050Ti + Intel 630
FullHD 60Hz IPS screen

So there seems to be some sort of cap on my fps when running games and I can't figure out what is causing it... I tried playing Fallout 3 but it was only getting 30fps with about 5fps variance.. no matter the settings whether maxed or low it would sit at 30 fps very rarely hitting 40 fps and not getting lower than 20 fps... I even tried lowering the resolution which also did nothing. Eventually I tried the game in windowed mode and it ran the game on max setting at 60+ fps.

Then I tried The Witcher 2 which also sat on 30fps very rarely hitting 40 fps and occasionally getting as low as 15 fps. Changing the resolution or graphics settings didn't affect the fps (at one point I set the resolution to 800-600 - still ran at 30)... Unlike Fallout 3 changing the game to windowed mode didn't change the fps other than in the intro screen.

Last of all I tried League of Legends.... It ran at 30fps too - changing the setting did nothing. There has got to be something wrong - my previous laptop had a graphics card that wasn't even meant for gaming and it ran League at 50fps on medium settings.

I have checked the graphics card drivers and they are up to date.

Also everyday browsing and navigating is quite laggy.

[ Register or Signin to view external links. ] - Here is the benchmark...

Any help or info would be appreciated
#2. Posted:
Potion
  • Moderator
Status: Offline
Joined: Mar 09, 20126 Year Member
Posts: 5,249
Reputation Power: 2766
Motto: Sophrosyne.
According to your user benchmark you do not have the proper drivers installed.

I would recommend running the latest driver installer from here [ Register or Signin to view external links. ]

Also when you are playing a game make sure that the game is using the 1050Ti and no the Integrated gpu.

Also your CPU is performing severely below expectations. I would check and see what programs are running in the background. Seriously consider doing a fresh install of Windows to remove any factory preinstalled bloat.
#3. Posted:
Status: Offline
Joined: Sep 27, 20153 Year Member
Posts: 2
Reputation Power: 0
Mmm I noticed that. Any idea what the reason for the CPU preforming so bad? Surely bloatware wouldn't make it preform that bad. I checked task manager to get the graphs of the CPU usage and it is usually running below 25% - the average while browsing is probably around 10%.. (Not sure if this is relevant but yeah) - the clock speed seems to sit on 0.78Ghz constantly with no variation... The intel 7700HQ is meant to be clocked at 2.8Ghz & have over 3Ghz boost... yeah it is not moving at all. Opening tabs or programs doesn't seem to budge it. (It should vary right? - or am I just sounding stupid?)
I don't think it has anything to do with the temperature of the laptop either . . the computer hardly gets hot to the touch - barely even warm. And it is only a month old so the fans and stuff shouldn't be clogged up.

I also downloaded Nvidia's driver program - it seems to be saying my drivers are up to date. It did pretty decently in the benchmarks anyway.
Yeah I made sure it was the Nvidia GPU - The Witcher 2 definitely wouldn't run at 30 fps on high if it was the intel 630. Plus I checked that it was being utilized for every game so far.

So that said... I'm guessing the CPU is throttling the whole system
#4. Posted:
Potion
  • Moderator
Status: Offline
Joined: Mar 09, 20126 Year Member
Posts: 5,249
Reputation Power: 2766
Motto: Sophrosyne.
Zenokue wroteMmm I noticed that. Any idea what the reason for the CPU preforming so bad? Surely bloatware wouldn't make it preform that bad. I checked task manager to get the graphs of the CPU usage and it is usually running below 25% - the average while browsing is probably around 10%.. (Not sure if this is relevant but yeah) - the clock speed seems to sit on 0.78Ghz constantly with no variation... The intel 7700HQ is meant to be clocked at 2.8Ghz & have over 3Ghz boost... yeah it is not moving at all. Opening tabs or programs doesn't seem to budge it. (It should vary right? - or am I just sounding stupid?)
I don't think it has anything to do with the temperature of the laptop either . . the computer hardly gets hot to the touch - barely even warm. And it is only a month old so the fans and stuff shouldn't be clogged up.

I also downloaded Nvidia's driver program - it seems to be saying my drivers are up to date. It did pretty decently in the benchmarks anyway.
Yeah I made sure it was the Nvidia GPU - The Witcher 2 definitely wouldn't run at 30 fps on high if it was the intel 630. Plus I checked that it was being utilized for every game so far.

So that said... I'm guessing the CPU is throttling the whole system


I am not familiar with mobile chips but that definitely is not normal for your CPU. You may want to check your power usage settings as well as fiddling with your bios (try resetting your bios to default).
Users browsing this topic: None
Jump to:


RECENT POSTS

HOT TOPICS