AdviceRTX 3080ti swap
Posted:

AdviceRTX 3080ti swapPosted:

Michaeldodell
  • New Member
Status: Offline
Joined: Dec 15, 2022
Posts: 1
Reputation Power: 0
Status: Offline
Joined: Dec 15, 2022
Posts: 1
Reputation Power: 0
Hi there I am running into an issues I've never dealt with before.

Firstly my PC is about 12 years old. I am running a Enermax Platnimax 1200 watt PSU and am swapping out my GPU. My origional GPU was an EVGA GTX 590 and I'm swapping to an EVGA RTX 3080ti FTW.

The 590 ran off of 2 8 pin connectors and the 3080 runs off of 3 8 pin connectors.

Everything was running fine, all I changed was the GPUs. When I have the 3080 hooked up the power supply makes a click, click, click noise then nothing. No lights no motherboard boot just nothing. I have to turn off the PSU and unplug it for it to even be able to try to push the PC power button again. If I put my old 590 in it boots up and runs great.

I've already tried 2 3080 cards both with the same issue. So it's some sort of power issue but I dont know if I'm over powering the GPU or under powering it. EVGA recommends at least a 750 watt PSU for the 3080.

Any help or advice is greatly appreciated. Thanks
#2. Posted:
154
  • Christmas!
Status: Offline
Joined: May 04, 20148Year Member
Posts: 2,743
Reputation Power: 4455
Motto: https://brad.bz/
Motto: https://brad.bz/
Status: Offline
Joined: May 04, 20148Year Member
Posts: 2,743
Reputation Power: 4455
Motto: https://brad.bz/
What motherboard, CPU & ram have you got for your current system you're trying to run it with?

Your power supply wattage is fine, I'm running a 650 with my 3080 and never had any power trips.
#3. Posted:
FoxServices
  • Trusted Seller
Status: Offline
Joined: Mar 19, 201111Year Member
Posts: 1,155
Reputation Power: 6737
Motto: Discord: Gray Fox#0001
Motto: Discord: Gray Fox#0001
Status: Offline
Joined: Mar 19, 201111Year Member
Posts: 1,155
Reputation Power: 6737
Motto: Discord: Gray Fox#0001
Michaeldodell wrote Hi there I am running into an issues I've never dealt with before.

Firstly my PC is about 12 years old. I am running a Enermax Platnimax 1200 watt PSU and am swapping out my GPU. My origional GPU was an EVGA GTX 590 and I'm swapping to an EVGA RTX 3080ti FTW.

The 590 ran off of 2 8 pin connectors and the 3080 runs off of 3 8 pin connectors.

Everything was running fine, all I changed was the GPUs. When I have the 3080 hooked up the power supply makes a click, click, click noise then nothing. No lights no motherboard boot just nothing. I have to turn off the PSU and unplug it for it to even be able to try to push the PC power button again. If I put my old 590 in it boots up and runs great.

I've already tried 2 3080 cards both with the same issue. So it's some sort of power issue but I dont know if I'm over powering the GPU or under powering it. EVGA recommends at least a 750 watt PSU for the 3080.

Any help or advice is greatly appreciated. Thanks


You're probably going to need to upgrade more of your computer if its 12 years old. Whats the other specs on your PC like your mobo, cpu, etc?
Users browsing this topic: None
Jump to:


RECENT POSTS

HOT TOPICS