GeneralPC wont display to monitorPosted:

Gush
  • V5 Launch
Status: Offline
Joined: Aug 08, 20125 Year Member
Posts: 1,207
Reputation Power: 50
Video card - MSI Radeon RXN 480 8GB

Pc turns on but will not display on the screen, i have been stuck clueless for the past couple days why its doing this, i removing video card and putting it back in still wont work If anyone knows whats going on please let me no.
#2. Posted:
Craig
  • E3 2017
Status: Offline
Joined: Jan 16, 20125 Year Member
Posts: 16,891
Reputation Power: 1460
Motto: Hello Party People! This Is Captain Kim Speaking... Welcome Aboard Venga Airways... After Take Off Will Pump Up The Soundsystem, Cause We're Going To Ibiza!!!! I Don't Wanna Be A Busdriver.... All My Life
Have you re-seated the RAM? Sometimes on new builds, RAM is the problem causing the PC to not post.
#3. Posted:
Z06
  • V5 Launch
Status: Offline
Joined: Feb 27, 20125 Year Member
Posts: 2,757
Reputation Power: 355
Does your mobo have a debug?
#4. Posted:
TastyCashews
  • Gold Member
Status: Offline
Joined: Aug 03, 20125 Year Member
Posts: 290
Reputation Power: 14
Motto: "Cash me in the Technology forums, how bout dat?"
If you have more than two sticks of ram, try putting just one of them in at a time and then seeing if you get a display. My bet its the ram. Also, do you get a post sound if you have no ram in the computer?
#5. Posted:
Gush
  • 1K Rainmaker
Status: Offline
Joined: Aug 08, 20125 Year Member
Posts: 1,207
Reputation Power: 50
I have 3 sticks of ram one 8gb and 2 4gb sricks i tried taking taking them out and putting them back in... still nothing
#6. Posted:
Gush
  • 1K Rainmaker
Status: Offline
Joined: Aug 08, 20125 Year Member
Posts: 1,207
Reputation Power: 50
I took the 8gb one out and just left the 2 4gb ones and it is still not displaying to monitor
#7. Posted:
Z06
  • 1K Rainmaker
Status: Offline
Joined: Feb 27, 20125 Year Member
Posts: 2,757
Reputation Power: 355
If you havent try only seating the 8gb
#8. Posted:
Jack_Sparrow
  • Summer Giveaway
Status: Offline
Joined: Mar 02, 20143 Year Member
Posts: 2,638
Reputation Power: 128
Have you tried using another cable?
#9. Posted:
USPS
  • Gold Member
Status: Offline
Joined: Dec 31, 20115 Year Member
Posts: 480
Reputation Power: 40
Gush wroteI took the 8gb one out and just left the 2 4gb ones and it is still not displaying to monitor


Are you sure the RAM is compatible and in the right slots?
Users browsing this topic: None
Jump to:


RECENT POSTS

HOT TOPICS