Car ForumCar Advice Needed For A 98 MustangPosted:

TnTEXTREME
  • V5 Launch
Status: Offline
Joined: Sep 01, 20115 Year Member
Posts: 685
Reputation Power: 29
Hi guys, so basically, i've been having a colossal amount of issues with one of my cars. The car in question is a 98 Mustang, it has the 3.8l in it. I've been wasting alot of money on it, just trying to solve ONE issue, then i discover more issues, and it really just has been a nightmare. The issue in question is basically it'll start jerking really hard when i try to accelerate, kinda seems like its trying to stall or something; but only if i get on the gas pedal moderate to hard. And The RPMS will barely climb and then stop climbing for a brief second when it jerks back. It is a manual and it shifts fine. But it'll rev fine in neutral and the RPMs will climb like normal while in neutral.

It only threw up 3 codes when i plugged an OBD scanner in it. 2 for 02 sensors (i removed the cats and the 02 sensors) and one code for the EGR valve, i replaced the EGR solenoid but that didn't do anything; but i don't think a faulty EGR valve is to blame for this issue.

After changing the solenoid, i reran most of the vacuum lines because none of them were sealed properly, so i fixed all the vacuum leaks, i replaced the coil pack, i replaced the spark plugs and spark plug wires, i made sure all the cylinders were firing properly, checked the firing order, did a full engine flush, changed the fuel filter, oil filter and now im just gonna check the fuel pressure and i guess work from there.

Any suggestions would really be appreciated, i've consulted so many different forums so i figured why not see if anyone in my favorite forum can give me an idea. Thanks in advance.
#2. Posted:
Status: Offline
Joined: Jun 14, 20116 Year Member
Posts: 280
Reputation Power: 13
I would suggest getting new catalytic converters. Had the same problem with my jeep. Spent a month and a half with it in the shop and over $4k on doing everything I could just to find my cats were worn out. Double check fuel filter and vacuum and go from there. Just my opinion from experience with my vehicle. Before you buy new cats, I'd look into the 02 sensors first.
#3. Posted:
TnTEXTREME
  • V5 Launch
Status: Offline
Joined: Sep 01, 20115 Year Member
Posts: 685
Reputation Power: 29
Well it doesn't have cats.. i took them off (the back pressure isn't messed up either) . the o2 sensors were removed since there aren't any cats on it; that's why they're throwing up a code.
#4. Posted:
322
  • Christmas!
Status: Offline
Joined: Dec 28, 20124 Year Member
Posts: 1,143
Reputation Power: 58
could it be the clutch slipping. My friend had a similar issue when he had a new clutch put in. It would jerk abit. the revs would get like stuck, then it would jerk a bit then climb. He didn't have any other issues, it shifted fine and all that.
#5. Posted:
yomama9999
  • Christmas!
Status: Offline
Joined: Jan 29, 20116 Year Member
Posts: 904
Reputation Power: 38
Have you tried to bring it to a shop and get them to inspect it and see if he can find the problem? My guy will either do it for free or about $50 depending on what he has to do. Has help me find problems that i could not figure out.
#6. Posted:
BigTunaDaBoss
  • Christmas!
Status: Offline
Joined: Jun 24, 20125 Year Member
Posts: 367
Reputation Power: 13
This might seem really simple but look at the air filter. It might be clogged. Also get O2 catless sensors like me that way you don't see that ugly check engine light.
#7. Posted:
TTGxL96SNIPES
  • Gold Member
Status: Offline
Joined: Aug 07, 20107 Year Member
Posts: 4,032
Reputation Power: 109
Motto: I still rock out
sounds like its caused you alot of grief. I have to ask though, why dump so much money into a v6 mustang? Sell it and step up to the 4.6L those were my fav for the stangs.
Users browsing this topic: None
Jump to:


RECENT POSTS

HOT TOPICS